Netherlands - Missing spot prices for May 7th
Incident Report for Tibber system status
Resolved
This incident has been resolved.
Posted May 06, 2024 - 14:50 CEST
Investigating
Prices are currently delayed - we are investigating the cause.
Posted May 06, 2024 - 14:42 CEST
This incident affected: Tibber Apps.