BMW - Pairing not working
Incident Report for Tibber system status
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 08:55 CET
Investigating
It is currently not possible to pair BMW to our app. We are investigating the issue.
Posted Nov 18, 2021 - 03:05 CET
This incident affected: Power-Ups (BMW).