Easee - Easee are experiencing issues with their app and other systems

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 08:27 CEST

Monitoring

A fix has been implemented and the results are being monitored.
Posted Jul 24, 2025 - 14:36 CEST

Investigating

Easee are currently investigating this issue.

The issue may impact your smart charging experience with Tibber.
You can follow the issue on Easee's Status Page: https://status.easee.com/incidents/xf72jqz8l203
Posted Jul 24, 2025 - 09:23 CEST
This incident affected: External API (Easee Easee Cloud & API, Easee Easee Portal).