Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2025 - 10:15 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 13, 2025 - 10:13 CET
Scheduled
We will be performing maintenance on our Polestar integration. This potentially could lead to some short disruptions with creating Smart Charging schedules.
Posted Mar 13, 2025 - 10:03 CET
This scheduled maintenance affected: Power-Ups (Polestar).