Tibber Support - support not reachable through the app

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 17:17 CEST

Investigating

We are currently investigating this issue.

If you need support, please send an e-mail to hello@tibber.com with the e-mailadres connected to your Tibber account and our support agents will help you.
Posted Jul 09, 2025 - 16:58 CEST
This incident affected: Tibber App (App).