ESDN, the central database, has fix the issue. We are monitoring the results.
Posted Jul 07, 2026 - 15:03 CEST
Investigating
A central database is down in the Netherlands. Customers will not be able to sign energy contracts with Tibber, and it will get an error in the Tibber-app and on the website when trying.
Posted Jul 07, 2026 - 09:42 CEST
This incident affected: Tibber App (Subscription).