A fix has been rolled out in Android version 25.26. If that version hasn't been automatically updated on your device please update manually and pair your car.
Posted Jul 17, 2025 - 15:25 CEST
Update
A fix has been implemented in app version 25.26 of the Android app which will be rolled out next week.
Posted Jul 04, 2025 - 11:53 CEST
Monitoring
A fix has been implemented in app version 25.24 of the Android app. Please update the app if you are experiencing problems with pairing.
Posted Jul 04, 2025 - 10:00 CEST
Investigating
We have discovered an error causing the log-in page to fail loading on Android-devices for the BMW and MINI power-ups. We are investigating.