Tibber Status

🟡 Tibber App - issues creating Tibber account

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 11:24 CET

Investigating

We are seeing that some users are experiencing issues when trying to create a Tibber account.

We are currently investigating this issue and will update this message as soon as we have more information.
Posted Feb 11, 2026 - 10:28 CET
This incident affected: Tibber App (App, Subscription).