Tibber Status

🔴 Account creation - issues creating a Tibber account in Germany using the iOS and Android app

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 16:26 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2026 - 11:39 CEST

Investigating

We are seeing issues with creating a new Tibber account in Germany using the Tibber app on both Android and iOS.
It's still possible to create a Tibber account on the German website.

We are currently investigating the issue and will update this message as soon as we have more information.
Posted Aug 20, 2026 - 10:23 CEST
This incident affected: Tibber App (App (General), Android app, iOS app).