Jaguar/Land Rover - Pairing issue
Incident Report for Tibber system status
Update
We are continuing to work for a fix for this issue.
Posted Sep 03, 2024 - 08:46 CEST
Investigating
Owners of Jaguar and Land Rover might experience difficulties in pairing/charging their vehicles. We are looking into this issue.

In the meantime, if there is an integrated charger present - add a non integrated car to smart charge instead.
Posted May 20, 2024 - 09:45 CEST
This incident affects: Power-Ups (Jaguar, Land Rover).