Grid Rewards earnings not visible in the app

Incident Report for Tibber

Resolved

Missing earnings have been restored in the app for affected users.
Posted Jan 02, 2026 - 09:18 CET

Update

We are in the process of restoring the visibility of earned Grid Rewards from the end of November and the beginning of December for customers who are still missing them. We expect the process to take a few weeks, due to the end-of-year holidays, before all data is fully processed.
Posted Dec 17, 2025 - 15:40 CET

Update

Some customers might not see all earned Grid Rewards displayed in the Grid Rewards screen and/or in the charging summary, and that previously listed earned Grid Rewards are missing.

This issue does not affect the calculation of rewards or compensation, meaning that you continue to charge at the cheaper rate, and the rewards will become visible in the Grid Rewards screen once the issue is resolved.

We are still investigating.
Posted Dec 09, 2025 - 08:54 CET

Investigating

Some customers might not see all earned Grid Rewards displayed in the Grid Rewards screen and/or charging summary.
We are currently investigating this issue.
Posted Dec 08, 2025 - 11:26 CET
This incident affected: Smart services (Grid Rewards).