Day ahead prices missing/delayed.
Incident Report for Tibber system status
Resolved
This incident has been resolved and day ahead prices is available in-app again.
Posted Jun 25, 2024 - 21:21 CEST
Identified
Due to an unforseen technicsl issue at NordPool, the prices for tomorrow are delayed. We will update this as soon as the prices are know to us.
Posted Jun 25, 2024 - 16:40 CEST
This incident affected: Tibber Apps.