Skoda: Pairing issue
Incident Report for Tibber system status
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 10:00 CEST
Investigating
Some users may experience issues with pairing their Skoda.

If you are experiencing issues, please attempt to log in to https://www.skoda-connect.com/ and make sure that all necessary permissions are given before attempting to pair your car to Tibber once more.
Posted Apr 19, 2024 - 11:25 CEST
This incident affected: Power-Ups (Škoda).