Tibber Status

Grid Rewards - Issues loading Grid Rewards-data in the app

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Jan 22, 2025 - 08:32 CET

Investigating

We are currently investigating this issue.
Posted Jan 21, 2025 - 10:59 CET
This incident affected: Tibber App (App (General)).