Tibber Webshop - currently not possible to pay orders

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted May 16, 2025 - 08:20 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 13:33 CEST

Update

Due to problems at our payment provider you can experience problems with paying for your webshop order.
Posted May 15, 2025 - 13:30 CEST

Investigating

We are currently investigating this issue.
Posted May 15, 2025 - 13:29 CEST
This incident affected: Tibber Store.