The 15-minute graph has been rolled out to all customers. Minimum app version required is 25.36.0. If you don’t see it yet, please force close the app and restart it
Posted Sep 30, 2025 - 16:20 CEST
Monitoring
Both German and Dutch prices are now available in the app.
Currently, the 15-minute prices are still displayed as 60-minute prices. We are working on showing the 15-minute price intervals in the app, and we expect to release the updated graph in the coming hours.
Posted Sep 30, 2025 - 14:39 CEST
Update
German prices are now available and we are waiting for the Dutch prices to come in.