Tibber App - home screen not loading for some customers using the iOS app

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 14:30 CEST

Monitoring

A fix has been implemented and we are monitoring the results.

If your home screen isn’t loading any widgets, you can try logging out and logging in again to resolve the issue. If you are still experiencing problems, please contact support.
Posted Jul 07, 2025 - 15:00 CEST

Investigating

We are currently investigating this issue.
Posted Jul 07, 2025 - 14:54 CEST
This incident affected: Tibber App (App).