Tibber Status

🔴 Android - Price widget missing in older app versions after app crash fix

Incident Report for Tibber

Resolved

A permanent solution has been released in a new app update. Please go to the Play Store and update the Tibber app to version 26.12.

After the app update, some users may see the price widget at the bottom of the home screen. To move it, press and hold the widget, then drag it to the desired position at the top of the screen.
Posted Mar 30, 2026 - 13:27 CEST

Update

A permanent solution has been released in a new app update. Please go to the Play Store and update the Tibber app to version 26.12.

After the app update, some users may see the price widget at the bottom of the home screen. To move it, press and hold the widget, then drag it to the desired position at the top of the screen.
Posted Mar 29, 2026 - 16:58 CEST

Monitoring

A permanent solution has been released in a new app update. Please go to the Play Store and update the Tibber app to version 26.12.
Posted Mar 29, 2026 - 10:36 CEST

Update

We have released a temporary fix by removing the price widget for today, and we will continue working on a definitive solution.

If the app keeps crashes for you, please clear the app's data memory on your Android device and restart the app. Go to Settings --> Apps, find the Tibber app --> storage and press clear data.

You can find today’s prices on our website:
NL: https://tibber.com/nl/stroomprijs
SE: https://tibber.com/se/elpriser
NO: https://tibber.com/no/strompriser
DE: https://tibber.com/de/strompreise

We apologise for the inconvenience.
Posted Mar 29, 2026 - 10:01 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 29, 2026 - 08:55 CEST

Investigating

We are experiencing issues with the app crashing and not being possible to open on Android-devices.
We are investigating the issue.

UPDATE:
A permanent solution has been released in a new app update. Please go to the Play Store and update the Tibber app to version 26.12.

After the app update, some users may see the price widget at the bottom of the home screen. To move it, press and hold the widget, then drag it to the desired position at the top of the screen.
Posted Mar 29, 2026 - 08:00 CEST
This incident affected: Tibber App (App (General)).