Some users signing a contract with the new Android app version may still experience issues when signing with BankID. We have prepared a hotfix for Android version 25.38, which will be rolled out as soon as possible.
In the meantime, the current workaround for Android users will remain in place: after completing the sign-up process in the app, you will receive an email with a BankID link to finalize your identification. Alternatively, you can also sign up through our website.
Posted Sep 25, 2025 - 22:10 CEST
Monitoring
A fix has been implemented in our Android app, version 25.36, which has now started to roll out. Within 7 days, the Play Store will gradually make this update available to all users.
Posted Sep 16, 2025 - 10:56 CEST
Update
The issue has been identified and only affects sign-up in the Android app.
We have implemented a workaround for Android users: after completing the sign-up process in the app, you will receive an email with a Bank-ID link to finalize your identification. Alternatively, you can sign up through our website.
If you experience any issues despite the workaround, please contact support, we’ll be happy to assist you.
We apologize for the inconvenience.
Posted Jul 03, 2025 - 13:22 CEST
Identified
The issue has been identified and only affects signup in the Android app. We are currently working on a fix.
In the meantime, you can sign up for a contract through our website or contact support.
We apologize for the inconvenience.
Posted Jul 03, 2025 - 11:22 CEST
Investigating
We are currently investigating this issue.
Posted Jul 03, 2025 - 11:05 CEST
This incident affected: Tibber App (Subscription).