Tibber Status

🔴 App - tomorrow's prices are not yet available in the app

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 16:26 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 16:10 CET

Investigating

Tomorrow's prices are not yet available in the app

We are currently investigating this issue.
As soon as we have more information we will update this message
Posted Mar 03, 2026 - 15:42 CET
This incident affected: Tibber App (Prices).