Delay in collecting invoices through Direct Debit in the Netherlands

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 14:54 CET

Monitoring

Due to a technical issue at our bank, the direct debit for October invoice of some customers, which was scheduled to be withdrawn on Tuesday 25 November, did not take place.

We will resubmit the direct debit within 1 to 3 working days. You don’t need to take any action. Please make sure there are sufficient funds in your bank account to cover the invoice amount.

As a result of the issue, the invoice currently shows an incorrect payment status in the Tibber app. We will correct the payment status before resubmitting the direct debit. You can view your invoices in the Tibber app via ‘you’ > ‘your invoices’.

We apologise for the inconvenience and any confusion this may have caused.

Do you have any questions? Feel free to contact us at hello@tibber.com or by sending a message in the Tibber app.
Posted Dec 02, 2025 - 16:18 CET

Investigating

Due to an issue at our bank, some invoices have not yet been debited. We are actively working with the bank to resolve the problem as soon as possible.

Please note that, in some cases, the invoice may incorrectly appear as “paid” in the app.

We expect the outstanding payments to be debited next week. We apologise for any inconvenience and appreciate your patience while we work to resolve this issue.
Posted Nov 28, 2025 - 13:51 CET
This incident affected: Tibber App (Subscription).