Tibber Webshop Netherlands - Order Checkout Issue

Incident Report for Tibber

Resolved

This incident has been resolved.
Posted 21 days ago. Apr 24, 2025 - 09:38 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 22 days ago. Apr 23, 2025 - 17:20 CEST

Investigating

We're currently experiencing an issue that prevents customers from completing their orders in the webshop.
Our team is actively investigating the problem.

Thank you for your patience.
Posted 22 days ago. Apr 23, 2025 - 16:55 CEST
This incident affected: Tibber Store.