Adax - Connectivity issue
Incident Report for Tibber system status
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 13:59 CEST
Investigating
We’re having issues adjusting to the correct temperature.
Posted Oct 14, 2024 - 10:08 CEST
This incident affected: Power-Ups (Adax).